JamomaCore doesn't build

classic Classic list List threaded Threaded
5 messages Options
tap
Reply | Threaded
Open this post in threaded view
|

JamomaCore doesn't build

tap

0.  On a Mac, I just cloned a fresh JamomaCore and switched to the dev branch.
1.  I tried "./build.rb dev clean" -- everything fails
2.  I tried "make" I get errors that seem to assume I'm on Linux, but I'm on a Mac
3.  I tried "cmake" but it tells me to specify some options or something
4.  I looked at ReadMe.md but it has no information
5.  There is no Install.md

What should I try next?

Tim


------------------------------------------------------------------------------

_______________________________________________
Jamoma-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jamoma-devel
Reply | Threaded
Open this post in threaded view
|

Re: JamomaCore doesn't build

Nils Peters
Hi Tim,

have you figure out how to build? I got stuck at the same stage.

cheers,
Nils

On 2015-08-11 7:23 AM, Timothy Place wrote:

>
> 0.  On a Mac, I just cloned a fresh JamomaCore and switched to the dev
> branch.
> 1.  I tried "./build.rb dev clean" -- everything fails
> 2.  I tried "make" I get errors that seem to assume I'm on Linux, but
> I'm on a Mac
> 3.  I tried "cmake" but it tells me to specify some options or something
> 4.  I looked at ReadMe.md but it has no information
> 5.  There is no Install.md
>
> What should I try next?
>
> Tim
>
>
>
> ------------------------------------------------------------------------------
>
>
>
> _______________________________________________
> Jamoma-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/jamoma-devel
>


------------------------------------------------------------------------------
_______________________________________________
Jamoma-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jamoma-devel
Reply | Threaded
Open this post in threaded view
|

Re: JamomaCore doesn't build

Antoine Villeret
Hi, 

I can't try right now, but cmake system should work.
Cmake just generate project file (Makefile, XCode project, Visual Studio solution...).
Usually, we make a build folder somewhere and run cmake from here then point to the Jamoma repo to configure it under the build folder.

For example : 

cd JamomaCore
mkdir build
cd build
cmake ..
make 

the '..' refer to the parent folder, which is in that particular case JamomCore (where a CMakelists.txt resides)
This used to work for me.

btw, if the ruby script should be fix fixed, could tell us more about what is failing ?

cheers

antoine

--
do it yourself                      
http://antoine.villeret.free.fr

2015-08-12 7:10 GMT+02:00 Nils Peters <[hidden email]>:
Hi Tim,

have you figure out how to build? I got stuck at the same stage.

cheers,
Nils

On 2015-08-11 7:23 AM, Timothy Place wrote:
>
> 0.  On a Mac, I just cloned a fresh JamomaCore and switched to the dev
> branch.
> 1.  I tried "./build.rb dev clean" -- everything fails
> 2.  I tried "make" I get errors that seem to assume I'm on Linux, but
> I'm on a Mac
> 3.  I tried "cmake" but it tells me to specify some options or something
> 4.  I looked at ReadMe.md but it has no information
> 5.  There is no Install.md
>
> What should I try next?
>
> Tim
>
>
>
> ------------------------------------------------------------------------------
>
>
>
> _______________________________________________
> Jamoma-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/jamoma-devel
>


------------------------------------------------------------------------------
_______________________________________________
Jamoma-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jamoma-devel


------------------------------------------------------------------------------

_______________________________________________
Jamoma-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jamoma-devel
tap
Reply | Threaded
Open this post in threaded view
|

Re: JamomaCore doesn't build

tap
Nils -- yes, I figured it out.  The YAML project for the Foundation was missing a file that had been added in the CMake files.
Antoine -- Thanks.  I will add your info the to the ReadMe.


Tim


On Wed, Aug 12, 2015 at 1:58 AM, Antoine Villeret <[hidden email]> wrote:
Hi, 

I can't try right now, but cmake system should work.
Cmake just generate project file (Makefile, XCode project, Visual Studio solution...).
Usually, we make a build folder somewhere and run cmake from here then point to the Jamoma repo to configure it under the build folder.

For example : 

cd JamomaCore
mkdir build
cd build
cmake ..
make 

the '..' refer to the parent folder, which is in that particular case JamomCore (where a CMakelists.txt resides)
This used to work for me.

btw, if the ruby script should be fix fixed, could tell us more about what is failing ?

cheers

antoine

--
do it yourself                      
http://antoine.villeret.free.fr

2015-08-12 7:10 GMT+02:00 Nils Peters <[hidden email]>:
Hi Tim,

have you figure out how to build? I got stuck at the same stage.

cheers,
Nils

On 2015-08-11 7:23 AM, Timothy Place wrote:
>
> 0.  On a Mac, I just cloned a fresh JamomaCore and switched to the dev
> branch.
> 1.  I tried "./build.rb dev clean" -- everything fails
> 2.  I tried "make" I get errors that seem to assume I'm on Linux, but
> I'm on a Mac
> 3.  I tried "cmake" but it tells me to specify some options or something
> 4.  I looked at ReadMe.md but it has no information
> 5.  There is no Install.md
>
> What should I try next?
>
> Tim
>
>
>
> ------------------------------------------------------------------------------
>
>
>
> _______________________________________________
> Jamoma-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/jamoma-devel
>


------------------------------------------------------------------------------
_______________________________________________
Jamoma-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jamoma-devel


------------------------------------------------------------------------------

_______________________________________________
Jamoma-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jamoma-devel



------------------------------------------------------------------------------

_______________________________________________
Jamoma-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jamoma-devel
Reply | Threaded
Open this post in threaded view
|

Re: JamomaCore doesn't build

Nils Peters
Thanks Tim, it compiles now.

best,
Nils

On 2015-08-12 5:38 AM, Timothy Place wrote:
> Nils -- yes, I figured it out.  The YAML project for the Foundation was
> missing a file that had been added in the CMake files.
> Antoine -- Thanks.  I will add your info the to the ReadMe.
>
>
> Tim
>
>


------------------------------------------------------------------------------
_______________________________________________
Jamoma-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/jamoma-devel